Ovdje pročitajte kako se registrirati na forum.

ETHERNET SHIELD S W5100 - neće inicijalizirati SD card

Tehnička podrška za sve ostale komponente s e-radionica.com
Odgovorite
zoran#8916
Novak
Novak
Postovi: 3
Pridružen/a: pet kol 17, 2018 10:41 am

ETHERNET SHIELD S W5100 - neće inicijalizirati SD card

Post Postao/la zoran#8916 » pet kol 17, 2018 10:56 am

Croduino BASIC 2 + adapter + Spomenuti shield, IDE 1.8.5, sketch iz examples: Card info - neće se inicijalizirati.

Probao sam niz različitih micro SD kartica od 1 Gb, 8Gb, 16 Gb, formatiranih na fat16.

Vidio na netu milijun takvih problema i savjeta kako staviti pin 10 na high da proradi, no meni neće...
A onda iz tih savjeta vidim da se mora uvijek ili ETH ili SD gasiti da bi drugi radio.

Ima li negdje upotrebljiv sketch sa obje funkcionalnosti?
Da dodate to na tutorijale, jer mi se ovo čini jako upotrebljiv shield?

Hvala!
Avatar
david.zovko#2594
e-radionica.com team
e-radionica.com team
Postovi: 260
Pridružen/a: ned tra 15, 2018 2:59 pm
Lokacija: Osijek, Croatia
Kontakt:

Re: ETHERNET SHIELD S W5100 - neće inicijalizirati SD card

Post Postao/la david.zovko#2594 » pon kol 20, 2018 12:24 pm

Pozdrav Zorane

žao mi je zbog problema. Meni zvuči ako problem s SPI komunikacijom.

Jel možeš probati napraviti konekciju putem ICSP konektora. To je ovaj konektor koji se nalazi sa zadnje strane W5100 shielda. Ovo su konekcije:

slika

Pazi samo na lokaciju prvog pina. Na konektoru na W5100 shieldu je označen s kružićem. S tog konektora povežeš na pinove 13, 12, 11, 10, 4 te napajanje na Croduinu. Pin 10 mora biti HIGH, a pin 4 bi u kodu trebao otići na LOW. Radi se o SPI komunikaciji pa samo jedan uređaj može biti aktivan u jednom trenutku. LOW stanje pina aktivira uređaj, a 4 je povezan na SD karticu(10 na Ethernet chip) tako da će ga to aktivirati.

Svakako bi trebalo dodati na tutorijale. Stavio sam kao visoki prioritet na naš interni popis. Bit će uskoro :)

Javi jesi li uspio!
Odgovorite